稼動環境 - 旧バージョン

SOAtest

Parasoft SOAtest 9.10.2 (Windows)

システム要件
  • 64-bit (x86_64) プロセッサ 最小 2 コア (4 コア以上を推奨)   ※ 32bit版の提供も可能です
  • Java 8 以降
  • SOAtest に設定するメモリ:
    最小 1 GB RAM (2 GB 以上を推奨); Load Test で高負荷を生成する場合はよりさらに必要となる可能性があります。
    例:soavirt.exe -J-Xms1024m -J-Xmx2048m
   
オペレーティングシステム
  • Windows 7
  • Windows 8.x
  • Windows 10
  • Windows Server 2008
  • Windows Server 2012
  • Windows Server 2016

Data Repository サーバー
  • 64-bit 版の Windows 2008 R2 以降
  • 以下の Linux 64-bit ディストリビューション:
    • Amazon
    • Debian 7
    • RHEL 5, 6, 7
    • SUSE 11
    • Ubuntu 12.04, 14.04, 14.10

Parasoft SOAtest 9.10.2 (Linux)

システム要件
  • 64-bit (x86_64) プロセッサ 最小 2 コア (4 コア以上を推奨)
  • Java 8 以降
  • SOAtest に設定するメモリ:
    最小 1 GB RAM (2 GB 以上を推奨); Load Test で高負荷を生成する場合はよりさらに必要となる可能性があります。
    例:soavirt.exe -J-Xms1024m -J-Xmx2048m

オペレーティングシステム
  • Linux
その他
  • GTK+ 2.18 以降
  • GLib 2.17.6 以降
  • Pango 1.20 以降
  • X.Org 1.0 以降
  • デフォルトのフォント サイズ 8 を推奨。たとえば、Ubuntu では次のターミナルを使用します:
    gsettings set org.gnome.desktop.interface font-name 'Ubuntu 8'

Data Repository サーバー
  • 64-bit 版の Windows 2008 R2 以降
  • 以下の Linux 64-bit ディストリビューション:
    • Amazon
    • Debian 7
    • RHEL 5, 6, 7
    • SUSE 11
    • Ubuntu 12.04, 14.04, 14.10

SOAtest 9.10.2 に関する稼動環境は、2017 年 05 月 01 日時点の情報です。
2017 年 05 月 01 日以降に稼動環境に記載されている製品の新バージョンがリリースされた場合は、その新バージョンにおける SOAtest 9.10.2 の動作は保証やサポートの対象にはなりません(サポートの対象外です)。


Parasoft SOAtest 9.9.3 (Windows)

システム要件
  • 32-bit または 64-bit (x86_64) プロセッサ 最小 2 コア (4 コア以上を推奨)
  • Java 7 以降
  • メモリ:最小 1 GB RAM (2 GB 以上を推奨); Load Test は高負荷によりさらに必要となる可能性があります。

オペレーティングシステム
  • Windows 7
  • Windows 8.x
  • Windows 10
  • Windows Server 2008
  • Windows Server 2012

IDE(プラグイン版を使用して既存のIDEと統合する場合)
  • Eclipse 3.5.2 - 4.x または Rational Application Developer 8.0
  • Sun Microsystems JRE 1.5 以降

Parasoft SOAtest 9.9.3 (Linux)

システム要件
  • 32-bit または 64-bit (x86_64) プロセッサ 最小 2 コア (4 コア以上を推奨)
  • Java 7 以降
  • メモリ:最小 1 GB RAM (2 GB 以上を推奨); Load Test は高負荷によりさらに必要となる可能性があります。
  • デフォルトのフォント サイズ 8 を推奨。たとえば、Ubuntu では次のターミナルを使用します: gsettings set org.gnome.desktop.interface font-name 'Ubuntu 8' (スタンドアロン版)

オペレーティングシステム
  • Linux

IDE(プラグイン版を使用して既存のIDEと統合する場合)
  • Eclipse 5.2 - 4.x または Rational Application Developer 8.0
  • Sun Microsystems JRE 1.5 以降

その他
  • GTK+ 2.18 以降、GLib 2.17.6 以降、Pango 1.20 以降、X.Org 1.0 以降

Parasoft SOAtest 9.7 (Windows)

システム要件
  • 32-bit または 64-bit (x86_64プロセッサ)
  • Java 6 以降
  • メモリ:1GB 以上(推奨:2GB 以上); Load Test は高負荷によりさらに必要となる可能性があります。

オペレーティングシステム
  • Windows XP Service Pack 2以降 (Professional Edition または Server Edition)
  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows Server 2008
  • Windows Server 2012

IDE(プラグイン版を使用して既存のIDEと統合する場合)
  • Eclipse 3.4~3.8、または、Rational Application Developer 7.5 / 8.0
  • Sun Microsystems JRE 1.5 以降

Parasoft SOAtest 9.7 (Linux)

システム要件
  • 32-bit または 64-bit (x86_64プロセッサ)
  • Java 6 以降
  • メモリ:1GB 以上(推奨:2GB 以上); Load Test は高負荷によりさらに必要となる可能性があります。

オペレーティングシステム
  • Linux

IDE(プラグイン版を使用して既存のIDEと統合する場合)
  • Eclipse 3.4~3.8、または、Rational Application Developer 7.5 / 8.0
  • Sun Microsystems JRE 1.5 以降

その他
  • GTK+ 2.10 以降、GLib 2.12 以降、Pango 1.14 以降、X.Org 1.0 以降

SOAtest 9.5(Windows)

システム要件
  • 32-bit もしくは 64-bit (x86_64プロセッサ)
  • Java 6以降
  • メモリ:1GB以上(推奨:2GB以上)

オペレーティングシステム
  • Windows XP Service Pack 2以降 (Professional Edition または Server Edition)
  • Windows Vista
  • Windows 2008
  • Windows 7
  • Windows 8

IDE(プラグイン版を使用して既存のIDEと統合する場合)
  • Eclipse 3.4~3.8、または、Rational Application Developer 7.5 / 8.0
  • Sun Microsystems JRE 1.5 以上

SOAtest 9.5(Linux)

システム要件
  • 32-bit もしくは 64-bit (x86_64プロセッサ)
  • Java 6以降
  • メモリ:1GB以上(推奨:2GB以上)
オペレーティングシステム
  • Linux
IDE(プラグイン版を使用して既存のIDEと統合する場合)
  • Eclipse 3.4~3.8、または、Rational Application Developer 7.5 / 8.0
  • Sun Microsystems JRE 1.5 以上
その他
  • GTK2.10 以上、GLib 2.12 以上、Pango 1.14 以上、X.Org 1.0 以上

SOAtest 9.5(Solaris)

システム要件
  • 32-bit もしくは 64-bit (x86_64プロセッサ)
  • Java 6以降
  • メモリ:1GB以上(推奨:2GB以上)
オペレーティングシステム
  • Solaris
IDE(プラグイン版を使用して既存のIDEと統合する場合)
  • Eclipse 3.4~3.8
  • Sun Microsystems JRE 1.5 以上

SOAtest 9.2(Windows)

32bit / 64bit 共通
  • Windows 2000
  • Windows 2003
  • Windows XP (Professional Edition または Server Edition)
  • Windows Vista
  • Windows 2008
  • Windows 7
  • 32-bit もしくは 64-bit (x86 互換プロセッサ)
  • メモリ:1GB以上(推奨:2GB以上)
  • Sun Microsystems JRE 1.5以上
  • プラグイン可能な環境:Eclipse 3.4~3.7、または、Rational Application Developer 7.5 / 8.0

SOAtest 9.2(Linux)

32bit / 64bit 共通
  • GTK2.10 以上、GLib 2.12 以上、Pango 1.14 以上、X.Org 1.0 以上
  • 32bit もしくは 64bit (x86 互換プロセッサ)
  • メモリ:1GB以上(推奨:2GB以上)
  • Sun Microsystems JRE 1.5以上
  • プラグイン可能な環境:Eclipse 3.4~3.7、または、Rational Application Developer 7.5 / 8.0

SOAtest 9.2(Solaris)

32bit
  • メモリ:1GB以上(推奨:2GB以上)
  • Sun Microsystems JRE 1.5以上
  • プラグイン可能な環境:Eclipse3.2.1~3.6

SOAtest 9.0(Windows)

32bit / 64bit 共通
  • Windows 2000
  • Windows 2003
  • Windows XP (Professional Edition または Server Edition)
  • Windows Vista
  • Windows 2008
  • Windows 7
  • 32-bit もしくは 64-bit (x86 互換プロセッサ)
  • Sun Microsystems JRE 1.5以上
  • メモリ:1GB以上(推奨:2GB以上)
  • プラグイン可能な環境:Eclipse3.2.1~3.6

SOAtest 9.0(Linux)

32bit / 64bit 共通
  • GTK2.10 以上、GLib 2.12 以上、Pango 1.14 以上、X.Org 1.0 以上
  • 32bit もしくは 64bit (x86 互換プロセッサ)
  • Sun Microsystems JRE 1.5以上
  • メモリ:1GB以上(推奨:2GB以上)
  • プラグイン可能な環境:Eclipse3.2.1~3.6

SOAtest 9.0(Solaris)

32bit
  • Sun Microsystems JRE 1.5以上
  • メモリ:1GB以上(推奨:2GB以上)
  • プラグイン可能な環境:Eclipse3.2.1~3.6

SOAtest 5.5(Windows)

  • SOAtest Professional Edition
    • Windows 2000、Windows 2003、Windows XP (Professional Edition または Server Edition)、Windows Vista
    • JRE 1.5.0
    • DOS/V互換機
    • Pentium III 600MHz以上を搭載したコンピュータ
    • 1プロセッサあたり最低 512 MB のRAM
  • SOAtest Enterprise Edition
    (負荷テスト機能が含まれるEditionです。)
    • Windows 2000、Windows 2003、Windows XP (Professional Edition または Server Edition)、Windows Vista
    • JRE 1.5.0
    • DOS/V互換機
    • Pentium III 600MHz以上を搭載したコンピュータ (推奨2GHz以上)
    • 1プロセッサあたり最低 512 MB のRAM(推奨1024MB以上)

SOAtest 5.5(Linux)

  • SOAtest Professional Edition
    • Linux
    • JRE 1.5.0
    • 1プロセッサあたり最低 512 MB のRAM
  • SOAtest Enterprise Edition
    (負荷テスト機能が含まれるEditionです。)
    • Linux
    • JRE 1.5.0
    • 1プロセッサあたり最低 512 MB のRAM(推奨1024MB以上)

SOAtest 5.5(Solaris)

  • SOAtest Professional Edition
    • Solaris
    • JRE 1.5.0(Solarisでは、JRE 1.4.2)
    • 1プロセッサあたり最低 512 MB のRAM
  • SOAtest Enterprise Edition
    (負荷テスト機能が含まれるEditionです。)
    • Solaris
    • JRE 1.5.0(Solarisでは、JRE 1.4.2)
    • 1プロセッサあたり最低 512 MB のRAM(推奨1024MB以上)

Windows

SOAtest Professional Edition
  • Windows 2000、Windows 2003、Windows XP (Professional Edition または Server Edition)
  • JRE 1.4.2
  • DOS/V互換機
  • Pentium III 600MHz以上を搭載したコンピュータ
  • 1プロセッサあたり最低 512 MB のRAM

SOAtest Enterprise Edition
(負荷テスト機能が含まれるEditionです。)
  • Windows 2000、Windows 2003、Windows XP (Professional Edition または Server Edition)
  • JRE 1.4.2
  • DOS/V互換機
  • Pentium III 600MHz以上を搭載したコンピュータ (推奨2GHz以上)
  • 1プロセッサあたり最低 512 MB のRAM(推奨1024MB以上)

Linux

SOAtest Professional Edition
  • Linux
  • JRE 1.4.2
  • 1プロセッサあたり最低 512 MB のRAM

SOAtest Enterprise Edition
(負荷テスト機能が含まれるEditionです。)
  • Linux
  • JRE 1.4.2
  • 1プロセッサあたり最低 512 MB のRAM(推奨1024MB以上)

Solaris

SOAtest Professional Edition
  • Solaris
  • JRE 1.4.2
  • 1プロセッサあたり最低 512 MB のRAM

SOAtest Enterprise Edition
(負荷テスト機能が含まれるEditionです。)
  • Solaris
  • JRE 1.4.2
  • 1プロセッサあたり最低 512 MB のRAM(推奨1024MB以上)

Virtualize

Parasoft Virtualize 9.10.2 (Windows)

  • 64-bit (x86_64) プロセッサ 最小 4 コア (8 コア以上を推奨)
  • Java 8 以降
  • Virtualize に設定するメモリ:
    最小 2 GB RAM (4 GB 以上を推奨); 高負荷を処理する場合はよりさらに必要となる可能性があります。 
    例:soavirt.exe -J-Xms2048m -J-Xmx4096m

オペレーティングシステム
  • Windows 7
  • Windows 8.x
  • Windows 10
  • Windows Server 2008
  • Windows Server 2012
  • Windows Server 2016

Data Repository サーバー
  • 64-bit 版の Windows 2008 R2 以降
  • 以下の Linux 64-bit ディストリビューション:
    • Amazon
    • Debian 7
    • RHEL 5, 6, 7
    • SUSE 11
    • Ubuntu 12.04, 14.04, 14.10

Parasoft Virtualize 9.10.2 (Linux)

    ハードウェア
  • 64-bit (x86_64) プロセッサ 最小 4 コア (8 コア以上を推奨)
  • Java 8 以降
  • Virtualize に設定するメモリ:
    最小 2 GB RAM (4 GB 以上を推奨); 高負荷を処理する場合はよりさらに必要となる可能性があります。 
    例:soavirt.exe -J-Xms2048m -J-Xmx4096m

    オペレーティングシステム
  • Linux

    その他
  • GTK+ 2.18 以上
  • GLib 2.17.6 以上
  • Pango 1.20 以上
  • X.Org 1.0 以上
  • デフォルトのフォント サイズ 8 を推奨。たとえば、Ubuntu では次のターミナルを使用します:
    gsettings set org.gnome.desktop.interface font-name 'Ubuntu 8'

Data Repository サーバー
  • 64-bit 版の Windows 2008 R2 以降
  • 以下の Linux 64-bit ディストリビューション:
    • Amazon
    • Debian 7
    • RHEL 5, 6, 7
    • SUSE 11
    • Ubuntu 12.04, 14.04, 14.10

稼動環境は、2017 年 05 月 01 日時点の情報です。2017 年 05 月 01 日以降に、稼動環境に記載されている製品の新バージョンがリリースされた場合は、その新バージョンにおけるVirtualize 9.10.2 の動作は保証やサポートの対象にはなりません(サポートの対象外です)。

Parasoft Virtualize 9.9.3 (Windows)

    ハードウェア
  • 32-bit または 64-bit (x86_64) プロセッサ 最小 2 コア (4 コア以上を推奨)
  • Java 7 以降
  • メモリ:最小 1 GB RAM (2 GB 以上を推奨)
    オペレーティングシステム
  • Windows 7
  • Windows 8.x
  • Windows 10
  • Windows Server 2008
  • Windows Server 2012

Parasoft Virtualize 9.9.3 (Linux)

    ハードウェア
  • 32-bit または 64-bit (x86_64) プロセッサ 最小 2 コア (4 コア以上を推奨)
  • Java 7 以降
  • メモリ:最小 1 GB RAM (2 GB 以上を推奨)
    オペレーティングシステム
  • Linux
    その他
  • GTK+ 2.10 以上
  • GLib 2.12 以上
  • Pango 1.14 以上
  • X.Org 1.0 以上
  • デフォルトのフォント サイズ 8 を推奨。たとえば、Ubuntu では次のターミナルを使用します:
    gsettings set org.gnome.desktop.interface font-name 'Ubuntu 8'

Parasoft Virtualize 9.7 (Windows)

    ハードウェア
  • 32 ビットまたは64 ビット(x86_64)のプロセッサ
  • Java 6 以降
  • メモリ:2GB 以上
    オペレーティングシステム
  • Windows XP Service Pack 2 以降 (Professional Edition または Server Edition)
  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows Server 2008

Parasoft Virtualize 9.7 (Linux)

    ハードウェア
  • 32 ビットまたは64 ビット(x86_64)のプロセッサ
  • Java 6 以降
  • メモリ:2GB 以上
    オペレーティングシステム
  • Linux
    その他
  • GTK+ 2.10 以上
  • GLib 2.12 以上
  • Pango 1.14 以上
  • X.Org 1.0 以上

Parasoft Virtualize 9.5 (Windows)

    ハードウェア
  • 32 ビットまたは64 ビット(x86_64)のプロセッサ
  • Java 6以降
  • メモリ:2GB以上
    オペレーティングシステム
  • Windows XP Service Pack 2以降 (Professional Edition または Server Edition)
  • Windows Vista
  • Windows 2008
  • Windows 7
  • Windows 8

Parasoft Virtualize 9.5 (Linux)

    ハードウェア
  • 32 ビットまたは64 ビット(x86_64)のプロセッサ
  • Java 6以降
  • メモリ:2GB以上
    オペレーティングシステム
  • Linux
    その他
  • GTK+ 2.10 以上
  • GLib 2.12 以上
  • Pango 1.14 以上
  • X.Org 1.0 以上

Parasoft Virtualize 9.3 (Windows)

    ハードウェア
  • 32 ビットまたは64 ビット(x86_64)のプロセッサ
  • メモリ:2GB以上
    オペレーティングシステム
  • Windows 2000
  • Windows 2003
  • Windows XP (Professional Edition または Server Edition)
  • Windows Vista
  • Windows 2008
  • Windows 7

Parasoft Virtualize 9.3 (Linux)

    ハードウェア
  • 32 ビットまたは64 ビット(x86_64)のプロセッサ
  • メモリ:2GB以上
    オペレーティングシステム
  • Linux
    その他
  • GTK+ 2.10 以上
  • GLib 2.12 以上
  • Pango 1.14 以上
  • X.Org 1.0 以上

APIのテスト自動化とサービス仮想化を1ツールで SOAtest/Virtualizeに
関するお問い合わせ

  • テクマトリックス株式会社
    東京本社

    ソフトウェアエンジニアリング事業部

    03-4405-7853

メールでのお問い合わせ
parasoft-info@techmatrix.co.jp

CONTACT

製品についてやテクマトリックスについてなど、
こちらよりお気軽にお問い合わせいただけます。